Jump to content
BloodPuddles

Hello, please help me.

Recommended Posts

Hello there. So I know support is on vacation, but I was curious if someone could give me some info. I'm not able to connect to the game. I'm trying to play through steam on Linux. It was working fine yesterday, now it's just getting stuck in an infinite connecting loop. Is this maintenance, or a server problem?  I'm hoping it's not on my end because this is one of very few games I can play, Diablo 2 even makes my CPU overheat. There's a good chance I did mess something up though, Linux is a very hands on OS, and I have absolutely no clue what I'm doing with it.

Share this post


Link to post
Share on other sites

I don't think it's that, I've been on Neverwinter and PSO2 on and off most of the day, and those have been running fine. My PS4 usually lags a lot harder than the computer too. Thanks for the reply though.

Edited by BloodPuddles

Share this post


Link to post
Share on other sites
On 12/30/2018 at 5:01 AM, BloodPuddles said:

I don't think it's that, I've been on Neverwinter and PSO2 on and off most of the day, and those have been running fine. My PS4 usually lags a lot harder than the computer too. Thanks for the reply though.

Try to reset connections 🙂

Sometimes it is because too many players logging at same time

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×